jaguar_example_upload_file 2.4.1

upload_file #

Example that shows how to upload files using Jaguar server.

Learn how to decode multipart/form-data using bodyAsFormData method to upload files.

Tutorial #

Upload files using Jaguar.dart

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  jaguar_example_upload_file: ^2.4.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Binary only

Cannot assign flutter SDK tag because it is binary only

Binary only

Cannot assign flutter platform tags, it is a binary only package

Health suggestions

Fix bin/client.dart. (-1.49 points)

Analysis of bin/client.dart reported 3 hints:

line 10 col 16: Unnecessary new keyword.

line 12 col 19: Unnecessary new keyword.

line 14 col 21: Unnecessary new keyword.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: Documenting jaguar_example_upload_file... Initialized dartdoc with 37 libraries in 31.6 seconds Validating docs... no issues found Documented 0 public libraries in 5.5 seconds stderr: Unhandled exception: dartdoc could not find any libraries to document #0 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:218:9)

Provide a file named (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (http).

Fix analysis_options.yaml.

The analyzer can't parse analysis_options.yaml.

Package is getting outdated. (-80.27 points)

The package was last published 94 weeks ago.

The package description is too short. (-2 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.11.3 0.11.3+17 0.12.1
jaguar ^2.4.4 2.4.43
jaguar_client ^2.4.0 2.4.2
jaguar_dev_proxy ^2.4.0 2.4.4
jaguar_resty ^2.8.0 2.8.9 2.10.15
path ^1.6.2 1.7.0
stencil ^2.1.1 2.1.6
Transitive dependencies
async 2.4.2
auth_header 2.1.4
charcode 1.1.3
client_cookie 2.1.5 2.2.1
collection 1.14.13
convert 2.1.1
crypto 2.1.5
http_parser 3.1.4
http_server 0.9.8+3
jaguar_common 2.1.4
jaguar_serializer 2.2.12
logging 0.11.4
meta 1.2.1
mime 0.9.6+3
path_tree 2.2.2
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
Dev dependencies
build_runner ^0.10.0
build_web_compilers ^0.4.0