jaguar_auth_mongo 2.4.1
jaguar_auth_mongo: ^2.4.1 copied to clipboard

MongoDb backed UserFetcher for authentication and authorization. Use it with `jaguar_auth`.

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Oct 17, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 8 API elements (37.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:jaguar_auth_mongo/jaguar_auth_mongo.dart that imports:
  • package:jaguar_auth_mongo/src/auth_mongo.dart that imports:
  • package:jaguar/jaguar.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
auth_header^2.1.12.1.43.0.1
jaguar^2.4.42.4.463.0.12
jaguar_auth^2.4.12.4.42.4.4
jaguar_common^2.1.12.1.43.0.0
jaguar_mongo^2.4.12.4.12.4.1
jaguar_serializer^2.2.02.2.122.2.12
mongo_dart^0.3.30.3.60.7.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
bson-0.3.41.0.3
characters-1.2.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
conn_pool-2.1.92.1.9
convert-2.1.13.0.1
crypto-2.1.53.0.1
fixnum-0.10.111.0.0
http_server-0.9.8+31.0.0
logging-0.11.41.0.2
meta-1.7.01.7.0
mime-0.9.71.0.0
mongo_dart_query-0.3.21.0.2
more-2.8.03.3.0
path-1.8.01.8.0
path_tree-2.2.43.0.0
pool-1.5.01.5.0
rational-0.3.81.2.1
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.5

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^2.1.1` on auth_header does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions auth_header to update the constraint.

The constraint `^2.4.4` on jaguar does not support the stable version `3.0.5`.

Try running dart pub upgrade --major-versions jaguar to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
80
pub points
0%
popularity

MongoDb backed UserFetcher for authentication and authorization. Use it with `jaguar_auth`.

Homepage (insecure)

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

auth_header, jaguar, jaguar_auth, jaguar_common, jaguar_mongo, jaguar_serializer, mongo_dart

More

Packages that depend on jaguar_auth_mongo