jafri_flutter_unity_widget 0.1.6+9
jafri_flutter_unity_widget: ^0.1.6+9

Flutter Android iOS

Flutter Unity 3D widget for embedding Unity game scenes in flutter. This library now supports Unity as a Library.

0
likes
85 / 110
pub points
0 %
popularity

We analyzed this package on Dec 3, 2020, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:5:1

  ╷
5 │ <a href="http://makeapullrequest.com"><img src="https://img.shields.io/badge/PRs-welcome-brightgreen.svg?style=flat-square" alt="PRs Welcome" /></a></p>
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 34 API elements (20.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:jafri_flutter_unity_widget/jafri_flutter_unity_widget.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/generated/i18n.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/jafri_flutter_unity_widget.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
85
pub points
0%
popularity

Flutter Unity 3D widget for embedding Unity game scenes in flutter. This library now supports Unity as a Library.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

syedjafri97@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on jafri_flutter_unity_widget