irrahub 0.0.3
irrahub: ^0.0.3 copied to clipboard

Helper package for Irrahub Team.

1
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on Jun 19, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://sanpyaelin.dev/post/irrahub-flutter was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 15 out of 77 API elements (19.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:irrahub/irrahub.dart that imports:
  • package:irrahub/widgets.dart that imports:
  • package:irrahub/src/widgets/main.dart that imports:
  • package:irrahub/src/widgets/data_display/main.dart that imports:
  • package:irrahub/src/widgets/data_display/future/loable.dart that imports:
  • package:connectivity/connectivity.dart that declares support for platforms: Android, iOS, macOS, Web
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/widgets/data_display/main.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity^0.4.90.4.9+53.0.6
flutterflutter0.0.00.0.0
http^0.12.20.12.20.13.3
intl^0.16.10.16.10.17.0
pull_to_refresh^1.6.01.6.52.0.0
shared_preferences^0.5.80.5.12+42.0.6
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
connectivity_for_web-0.3.1+40.4.0
connectivity_macos-0.1.0+70.2.0
connectivity_platform_interface-1.0.62.0.1
ffi-1.1.21.1.2
file-6.1.26.1.2
flutter_web_plugins-0.0.00.0.0
http_parser-3.1.44.0.0
js-0.6.30.6.3
meta-1.3.01.4.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.1
pedantic-1.11.11.11.1
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.2.02.2.0
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.4.9` on connectivity does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions connectivity to update the constraint.

The constraint `^0.12.2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

1
likes
60
pub points
0%
popularity

Publisher

sanpyaelin.dev

Helper package for Irrahub Team.

Homepage

Documentation

API reference

License

BSD (LICENSE)

Dependencies

connectivity, flutter, http, intl, pull_to_refresh, shared_preferences

More

Packages that depend on irrahub