ipin 0.0.6
ipin: ^0.0.6 copied to clipboard

Ipin encryption for EBS / noebs. ipin uses a very simple interface to calculate encrypted ipin for both EBS / noebs use cases. ipin is battle tested and used in production by different companies.

2
likes
90/ 130
pub points
22%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 7 API elements (28.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
crypton^1.1.31.1.32.0.2
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
asn1lib-0.8.11.0.2
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.3.01.7.0
pointycastle-2.0.13.3.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.3` on crypton does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions crypton to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Flutter 2.2.3, Dart 2.13.4.

2
likes
90
pub points
22%
popularity

Publisher

noebs.dev

Ipin encryption for EBS / noebs. ipin uses a very simple interface to calculate encrypted ipin for both EBS / noebs use cases. ipin is battle tested and used in production by different companies.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

crypton, flutter

More

Packages that depend on ipin