ipfinder 1.0.1
ipfinder: ^1.0.1 copied to clipboard

Official Dart client library for IPfinder. - IP address details. - ASN details. - Firewall by supported formats details. - IP Address Ranges by the Organization name details. - service status details.

5
likes
70 / 110
pub points
68 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too long.

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

0/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 458 API elements (7.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/ipfinder.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+20.12.20.13.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+2` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

5
likes
70
pub points
68%
popularity

Official Dart client library for IPfinder. - IP address details. - ASN details. - Firewall by supported formats details. - IP Address Ranges by the Organization name details. - service status details. - Get Domain IP. - Get Domain IP history. - Get list Domain By ASN, Country,Ranges.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

info@ipfinder.io

License

Apache 2.0 (LICENSE)

Dependencies

http

More

Packages that depend on ipfinder