intranet_ip 1.0.2 copy "intranet_ip: ^1.0.2" to clipboard
intranet_ip: ^1.0.2 copied to clipboard

get local intranet ip with tcp bind

110/ 140
pub points

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid

5/5 points: Provide a valid

10/10 points: Use an OSI-approved license

Detected license: MPL-2.0.

Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 2 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: intranet_ip, intranet_ip.intranetIpv4.

10/10 points: Package has an example

Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web


  • package:intranet_ip/intranet_ip.dart that imports:
  • dart:io
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'dart:async' is unnecessary because all of the used elements are also provided by the import of 'dart:core'.


4 │ import 'dart:async';
  │        ^^^^^^^^^^^^

To reproduce make sure you are using the lints_core and run dart analyze lib/intranet_ip.dart

Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
random_uint8list ^1.0.0 1.0.2 1.0.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.