intenthandler 0.1.7 copy "intenthandler: ^0.1.7" to clipboard
intenthandler: ^0.1.7 copied to clipboard

All functions done by the app will be done from a library

0
likes
120/ 140
pub points
21%
popularity

We analyzed this package 2 days ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: intenthandler,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository has no repository or homepage URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 19 API elements (21.1 %) have documentation comments.

Some symbols that are missing documentation: intenthandler, intenthandler.Intenthandler, intenthandler.Intenthandler.Intenthandler, intenthandler.Intenthandler.broadCastReceiverIntent, intenthandler.Intenthandler.callSdkIntent.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:intenthandler/intenthandler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:intenthandler/intenthandler.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:intenthandler/intenthandler.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:intenthandler/intenthandler.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/intenthandler.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/intenthandler_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

0
likes
120
pub points
21%
popularity

Publisher

unverified uploader

All functions done by the app will be done from a library

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on intenthandler