instant_xml_parser 1.1.2 copy "instant_xml_parser: ^1.1.2" to clipboard
instant_xml_parser: ^1.1.2 copied to clipboard

Code generator for instant_xml_parser. Reads specially annotated Dart code an emits an XML parser/deserializer to match.

1
likes
130/ 160
pub points
0%
popularity

We analyzed this package 18 hours ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

56 out of 104 API elements (53.8 %) have documentation comments.

Some symbols that are missing documentation: instant_xml_parser, ixp_core, ixp_core.AnnotationReader, ixp_core.AnnotationReader.AnnotationReader, ixp_core.AnnotationReader.getAnnotation.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:instant_xml_parser/instant_xml_parser.dart that imports:
  • package:instant_xml_parser/ixp_core.dart that imports:
  • package:instant_xml_parser/src/utils/annotation_reader.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:instant_xml_parser/instant_xml_parser.dart that imports:
  • package:instant_xml_parser/ixp_core.dart that imports:
  • package:instant_xml_parser/src/utils/annotation_reader.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:instant_xml_parser/instant_xml_parser.dart that imports:
  • package:instant_xml_parser/ixp_core.dart that imports:
  • package:instant_xml_parser/src/utils/annotation_reader.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The import of 'method_gen.dart' is unnecessary because all of the used elements are also provided by the import of 'package:instant_xml_parser/ixp_core.dart'.

lib/src/codegen/library_gen.dart:23:8

   ╷
23 │ import 'method_gen.dart';
   │        ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/codegen/library_gen.dart

INFO: An uninitialized field should have an explicit type annotation.

lib/src/codegen/library_gen.dart:38:7

   ╷
38 │   var _importUris;
   │       ^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/codegen/library_gen.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^2.0.0 2.8.0 6.7.0
build ^2.0.3 2.4.1 2.4.1
build_config ^1.0.0 1.1.1 1.1.1
code_builder ^4.1.0 4.10.0 4.10.0
collection ^1.15.0 1.19.0 1.19.0
dart_style ^2.0.3 2.2.1 2.3.6
ixp_runtime ^1.1.2 1.1.2 1.1.2
logging ^1.0.1 1.2.0 1.2.0
meta ^1.2.4 1.15.0 1.15.0
recase ^4.0.0 4.1.0 4.1.0
source_gen ^1.0.5 1.2.2 1.5.0
xml ^5.1.2 5.4.1 6.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 31.0.0 72.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
checked_yaml - 2.0.3 2.0.3
cli_util - 0.3.5 0.4.1
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
glob - 2.1.2 2.1.2
json_annotation - 4.9.0 4.9.0
matcher - 0.12.16+1 0.12.16+1
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
petitparser - 5.4.0 6.0.2
pub_semver - 2.1.4 2.1.4
pubspec_parse - 1.3.0 1.3.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on analyzer does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^5.1.2` on xml does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions xml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

1
likes
130
pub points
0%
popularity

Publisher

unverified uploader

Code generator for instant_xml_parser. Reads specially annotated Dart code an emits an XML parser/deserializer to match.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, build_config, code_builder, collection, dart_style, ixp_runtime, logging, meta, recase, source_gen, xml

More

Packages that depend on instant_xml_parser