instabug_flutter 10.13.0 copy "instabug_flutter: ^10.13.0" to clipboard
instabug_flutter: ^10.13.0 copied to clipboard

Deliver the best user experience through a comprehensive platform that will help you uncover, analyze and fix any app performance, quality or stability issues.

39
likes
80/ 140
pub points
93%
popularity

We analyzed this package 3 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

146 out of 292 API elements (50.0 %) have documentation comments.

Some symbols that are missing documentation: APM, APM.APM, APM.APM.APM, APM.APM.networkLogAndroid, APM.APM.platformVersion.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:instabug_flutter/APM.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:instabug_flutter/APM.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:instabug_flutter/APM.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:instabug_flutter/APM.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

ERROR: Missing concrete implementations of 'setter HttpClient.connectionFactory' and 'setter HttpClient.keyLog'.

lib/instabug_custom_http_client.dart:7:7

  ╷
7 │ class InstabugCustomHttpClient extends HttpClientLogger implements HttpClient {
  │       ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/instabug_custom_http_client.dart

WARNING: The operand can't be null, so the condition is always 'true'.

lib/APM.dart:66:18

   ╷
66 │       if (idBack != null) {
   │                  ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/APM.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
meta ^1.3.0 1.11.0 1.12.0
stack_trace ^1.10.0 1.11.1 1.11.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

39
likes
80
pub points
93%
popularity

Publisher

verified publisherinstabug.com

Deliver the best user experience through a comprehensive platform that will help you uncover, analyze and fix any app performance, quality or stability issues.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

unknown (LICENSE)

Dependencies

flutter, meta, stack_trace

More

Packages that depend on instabug_flutter