inherited_builder 1.0.1+8
inherited_builder: ^1.0.1+8

Autogenerated state management and dependency inhection with inherited widgets

1
likes
70 / 110
pub points
72 %
popularity

We analyzed this package on Nov 26, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 18 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 8 issues. Showing the first 2:

Consider supporting multiple platforms:

Package not compatible with runtime flutter-native on Android

Because:

  • package:inherited_builder/builder.dart that imports:
  • package:inherited_builder/generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.00.39.170.41.0
build>=0.12.6 <2.0.01.5.11.5.1
build_config>=0.2.6 <0.5.00.4.30.4.3
code_builder^3.2.03.5.03.5.0
dart_style^1.3.31.3.61.3.10
source_gen^0.9.4+50.9.80.9.8
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.013.0.0
args-1.6.01.6.0
async-2.4.22.5.0-nullsafety.3
built_collection-4.3.24.3.2
built_value-7.1.07.1.0
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
checked_yaml-1.0.21.0.2
cli_util-0.2.00.2.0
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
csslib-0.16.20.16.2
file-5.2.15.2.1
fixnum-0.10.110.10.11
glob-1.2.01.2.0
html-0.14.0+40.14.0+4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-3.1.13.1.1
logging-0.11.40.11.4
matcher-0.12.90.12.10-nullsafety.3
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.31.9.3
path-1.7.01.8.0-nullsafety.3
pedantic-1.9.21.9.2
pub_semver-1.4.41.4.4
pubspec_parse-0.1.50.1.5
quiver-2.1.52.1.5
source_span-1.7.01.8.0-nullsafety.4
stack_trace-1.9.61.10.0-nullsafety.6
string_scanner-1.0.51.1.0-nullsafety.3
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
watcher-0.9.7+150.9.7+15
yaml-2.2.12.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.39.0` on analyzer does not support the latest published version `0.41.0`

pubspec.yaml:12:13

   ╷
12 │   analyzer: "^0.39.0"
   │             ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
70
pub points
72%
popularity

Publisher

lesnitsky.dev

Autogenerated state management and dependency inhection with inherited widgets

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

analyzer, build, build_config, code_builder, dart_style, flutter, source_gen

More

Packages that depend on inherited_builder