infobip_mobilemessaging 5.1.0 copy "infobip_mobilemessaging: ^5.1.0" to clipboard
infobip_mobilemessaging: ^5.1.0 copied to clipboard

Infobip Mobile Messaging Flutter Plugin.

6
likes
100/ 140
pub points
85%
popularity

We analyzed this package 2 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

ERR: Unhandled exception: Null check operator used on a null value #0 _LintConfig._parseYaml.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:infobip_mobilemessaging/infobip_mobilemessaging.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:infobip_mobilemessaging/infobip_mobilemessaging.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:infobip_mobilemessaging/infobip_mobilemessaging.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:infobip_mobilemessaging/infobip_mobilemessaging.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: Missing a corresponding override of 'hashCode'.

lib/models/inbox/filter_options.dart:22:17

   ╷
22 │   bool operator ==(Object other) =>
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/inbox/filter_options.dart

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/models/installation.dart:76:54

   ╷
76 │         'pushServiceType': pushServiceType != null ? describeEnum(pushServiceType!) : null,
   │                                                      ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/installation.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

6
likes
100
pub points
85%
popularity

Publisher

unverified uploader

Infobip Mobile Messaging Flutter Plugin.

Homepage
Repository (GitHub)
View/report issues

License

unknown (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on infobip_mobilemessaging