inf_flutter_logger 0.0.1 copy "inf_flutter_logger: ^0.0.1" to clipboard
inf_flutter_logger: ^0.0.1 copied to clipboard

Console logger for development.

0
likes
110/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 110 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 18 API elements (22.2 %) have documentation comments.

Some symbols that are missing documentation: inf_flutter_logger, inf_flutter_logger.InfFlutterLogger, inf_flutter_logger.InfFlutterLogger.InfFlutterLogger, inf_flutter_logger.InfFlutterLogger.getPlatformVersion, inf_flutter_logger_method_channel.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:inf_flutter_logger/inf_flutter_logger.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:inf_flutter_logger/inf_flutter_logger.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:inf_flutter_logger/inf_flutter_logger.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:inf_flutter_logger/inf_flutter_logger.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/inf_flutter_logger_method_channel.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

0
likes
110
pub points
0%
popularity

Publisher

unverified uploader

Console logger for development.

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, plugin_platform_interface

More

Packages that depend on inf_flutter_logger