in_app_purchase_android 0.3.4 copy "in_app_purchase_android: ^0.3.4" to clipboard
in_app_purchase_android: ^0.3.4 copied to clipboard

PlatformAndroid
unlisted

An implementation for the Android platform of the Flutter `in_app_purchase` plugin. This uses the Android BillingClient APIs.

13
likes
130/ 140
pub points
97%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/flutter/flutter/issues?q=is%3Aissue+is%3Aopen+label%3A%22p%3A+in_app_purchase%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

273 out of 289 API elements (94.5 %) have documentation comments.

Some symbols that are missing documentation: billing_client_wrappers, billing_client_wrappers.BillingChoiceModeConverter.fromJson, billing_client_wrappers.BillingChoiceModeConverter.toJson, billing_client_wrappers.BillingClientFeatureConverter.fromJson, billing_client_wrappers.BillingClientFeatureConverter.toJson.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:in_app_purchase_android/in_app_purchase_android.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 23 issues. Showing the first 2:

INFO: 'fromJson' is deprecated and shouldn't be used. JSON serialization is not intended for public use, and will be removed in a future version.

lib/src/billing_client_wrappers/alternative_billing_only_reporting_details_wrapper.g.dart:13:16

   ╷
13 │               .fromJson(json['responseCode'] as int?),
   │                ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/billing_client_wrappers/alternative_billing_only_reporting_details_wrapper.g.dart

INFO: 'fromJson' is deprecated and shouldn't be used. JSON serialization is not intended for public use, and will be removed in a future version.

lib/src/billing_client_wrappers/billing_config_wrapper.g.dart:12:12

   ╷
12 │           .fromJson(json['responseCode'] as int?),
   │            ^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/billing_client_wrappers/billing_config_wrapper.g.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
in_app_purchase_platform_interface ^1.4.0 1.4.0 1.4.0
json_annotation ^4.8.0 4.8.1 4.8.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

13
likes
130
pub points
97%
popularity

Publisher

verified publisherflutter.dev

An implementation for the Android platform of the Flutter `in_app_purchase` plugin. This uses the Android BillingClient APIs.

Repository (GitHub)
View/report issues
Contributing

Topics

#in-app-purchase #payment

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter, in_app_purchase_platform_interface, json_annotation

More

Packages that depend on in_app_purchase_android