in_app_purchase 2.0.1 icon indicating copy to clipboard operation
in_app_purchase: ^2.0.1 copied to clipboard

A Flutter plugin for in-app purchases. Exposes APIs for making in-app purchases through the App Store and Google Play.

904
likes
110/ 130
pub points
98%
popularity

We analyzed this package 2 hours ago, and awarded it 110 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 11 API elements (90.9 %) have documentation comments.
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:in_app_purchase/in_app_purchase.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
in_app_purchase_android^0.2.10.2.2+10.2.2+1
in_app_purchase_platform_interface^1.0.01.3.11.3.1
in_app_purchase_storekit^0.2.00.2.10.3.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
json_annotation-4.4.04.4.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.2.0` on in_app_purchase_storekit does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions in_app_purchase_storekit to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.

904
likes
110
pub points
98%
popularity

Publisher

shield icon for verified publishersflutter.dev

A Flutter plugin for in-app purchases. Exposes APIs for making in-app purchases through the App Store and Google Play.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, in_app_purchase_android, in_app_purchase_platform_interface, in_app_purchase_storekit

More

Packages that depend on in_app_purchase