in_app_call_alert 0.0.4 icon indicating copy to clipboard operation
in_app_call_alert: ^0.0.4 copied to clipboard

A new Flutter package to show an alert screen.

8
likes
90/ 140
pub points
19%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 12 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ MacOS
  • ✓ Web

These platforms are not supported:

Package does not support platform Windows.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.

Package does not support platform Linux.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audioplayers.dart that declares support for platforms: Android, iOS, macOS, Web.

These issues are present but do not affect the score, because they may not originate in your package:

Package does not support platform Android.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.

Package does not support platform iOS.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.

Package does not support platform macOS.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that imports:
  • package:path_provider_windows/path_provider_windows.dart that declares support for platforms: Windows.

Package does not support platform Web.

Because:

  • package:in_app_call_alert/in_app_call_alert.dart that imports:
  • package:audioplayers/audio_cache.dart that imports:
  • package:path_provider/path_provider.dart that declares support for platforms: Android, iOS, Windows, Linux, macOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
audioplayers^0.16.20.16.21.1.1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.16.01.17.0
convert-2.1.13.1.1
crypto-2.1.53.0.2
ffi-1.2.12.0.1
file-6.1.46.1.4
flutter_web_plugins-0.0.00.0.0
js-0.6.40.6.5
material_color_utilities-0.1.50.2.0
meta-1.8.01.8.0
path-1.8.21.8.2
path_provider-1.6.282.0.11
path_provider_linux-0.0.1+22.1.7
path_provider_macos-0.0.4+82.0.6
path_provider_platform_interface-1.0.42.0.5
path_provider_windows-0.0.52.1.3
platform-3.1.03.1.0
plugin_platform_interface-1.0.32.1.3
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.11.3.1
uuid-2.2.23.0.7
vector_math-2.1.22.1.4
win32-2.6.13.1.2
xdg_directories-0.1.20.2.0+2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.16.2 on audioplayers does not support the stable version 0.17.0.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.7.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Flutter 3.3.9, Dart 2.18.5.

8
likes
90
pub points
19%
popularity

Publisher

verified publisher icondplyr.dev

A new Flutter package to show an alert screen.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

audioplayers, flutter

More

Packages that depend on in_app_call_alert