import_path 1.0.1
import_path: ^1.0.1 copied to clipboard

A tool to find the shortest import path from one dart file to another.

0
likes
90 / 130
pub points
21 %
popularity

We analyzed this package on May 14, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 0 API elements (100.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.00.39.171.5.0
package_config^1.9.01.9.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.021.0.0
args-1.6.02.1.0
async-2.6.12.6.1
charcode-1.2.01.2.0
cli_util-0.2.00.3.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
csslib-0.16.20.17.0
file-5.2.16.1.0
glob-1.2.02.0.1
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.3.01.3.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pub_semver-1.4.42.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.39.0` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.9.0` on package_config does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions package_config to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
90
pub points
21%
popularity

A tool to find the shortest import path from one dart file to another.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jakemac@google.com

License

BSD (LICENSE)

Dependencies

analyzer, package_config

More

Packages that depend on import_path