import_lint 0.9.4 icon indicating copy to clipboard operation
import_lint: ^0.9.4 copied to clipboard

The Import Lint package defines import lint rules and report on lints found in Dart code.

12
likes
130/ 140
pub points
83%
popularity

We analyzed this package 40 hours ago, and awarded it 130 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 53 API elements (11.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:import_lint/import_lint.dart that imports:
  • package:import_lint/src/utils.dart that imports:
  • package:analyzer/file_system/physical_file_system.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^5.2.05.2.05.2.0
analyzer_plugin>=0.11.0 <0.13.00.11.20.11.2
args^2.3.02.3.12.3.1
cli_util^0.3.50.3.50.3.5
glob^2.0.22.1.12.1.1
path^1.8.01.8.21.8.2
yaml^3.1.03.1.13.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-50.0.050.0.0
async-2.10.02.10.0
collection-1.17.01.17.0
convert-3.1.13.1.1
crypto-3.0.23.0.2
dart_style-2.2.42.2.4
file-6.1.46.1.4
meta-1.8.01.8.0
package_config-2.1.02.1.0
pub_semver-2.1.32.1.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
watcher-1.0.21.0.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.20, Dart 2.18.4.

12
likes
130
pub points
83%
popularity

Publisher

verified publisher iconkawa.dev

The Import Lint package defines import lint rules and report on lints found in Dart code.

Homepage
Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, analyzer_plugin, args, cli_util, glob, path, yaml

More

Packages that depend on import_lint