imin 0.0.1 copy "imin: ^0.0.1" to clipboard
imin: ^0.0.1 copied to clipboard

PlatformAndroid

A Imin Android Cashdrawer Wrapper.

3
likes
130/ 160
pub points
61%
popularity

We analyzed this package 23 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

* `pubspec.yaml` doesn't have a `homepage` entry. * `pubspec.yaml` doesn't have a `repository` entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 5 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: imin, imin.Imin, imin.Imin.Imin, imin.Imin.openDrawer, imin.Imin.platformVersion.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:imin/imin.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:imin/imin.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:imin/imin.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:imin/imin.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:imin/imin.dart that declares support for platforms: Android.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/imin.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
130
pub points
61%
popularity

Publisher

verified publishercloudpos.asia

A Imin Android Cashdrawer Wrapper.

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on imin