ime_pay 0.0.6 copy "ime_pay: ^0.0.6" to clipboard
ime_pay: ^0.0.6 copied to clipboard

Flutter plugin to integrate IME Pay in your Android and iOS app.

8
likes
130/ 140
pub points
48%
popularity

We analyzed this package 4 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 25 API elements (4.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: ime_pay, ime_pay.ImePay, ime_pay.ImePay.ImePay, ime_pay.ImePay.amount, ime_pay.ImePay.deliveryServiceUrl.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ime_pay/ime_pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:ime_pay/ime_pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:ime_pay/ime_pay.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:ime_pay/ime_pay.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

8
likes
130
pub points
48%
popularity

Publisher

verified publisherbibek-timsina.com.np

Flutter plugin to integrate IME Pay in your Android and iOS app.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on ime_pay