image_tool 0.2.2
image_tool: ^0.2.2 copied to clipboard

A Flutter package that organizes image's resolution variants inside your asset's folder. Add image list to pubspec.yaml for flutter packages.

0
likes
80 / 130
pub points
2 %
popularity

We analyzed this package on Jun 11, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 11 API elements (72.7 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:image_tool/image_tool.dart that imports:
  • package:image_tool/src/config.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/image_tool.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/config.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
path^1.6.21.8.01.8.0
watcher^0.9.7+120.9.7+151.0.0
yaml^2.1.162.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.7.02.7.0
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
meta-1.3.01.4.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.9.7+12` on watcher does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions watcher to update the constraint.

The constraint `^2.1.16` on yaml does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.17.1, Flutter 2.2.1, Dart 2.13.1.

0
likes
80
pub points
2%
popularity

Publisher

Unknown

A Flutter package that organizes image's resolution variants inside your asset's folder. Add image list to pubspec.yaml for flutter packages.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, path, watcher, yaml

More

Packages that depend on image_tool