image_compare_2 1.1.7 copy "image_compare_2: ^1.1.7" to clipboard
image_compare_2: ^1.1.7 copied to clipboard

Package maintained based on image_compare. Compare images using a variety of algorithms.

2
likes
140/ 140
pub points
68%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

44 out of 49 API elements (89.8 %) have documentation comments.

Some symbols that are missing documentation: image_compare_2, image_compare_2.RGBAHistogram.alphaHist, image_compare_2.RGBAHistogram.blueHist, image_compare_2.RGBAHistogram.greenHist, image_compare_2.RGBAHistogram.redHist.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:image_compare_2/image_compare_2.dart that imports:
  • package:image_compare_2/src/functions.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
image >=4.0.17 <6.0.0 4.1.7 4.1.7
universal_io >=2.0.0 <4.0.0 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.4.10 3.4.10
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
js - 0.7.1 0.7.1
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
petitparser - 6.0.2 6.0.2
pointycastle - 3.9.0 3.9.0
typed_data - 1.3.2 1.3.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

2
likes
140
pub points
68%
popularity

Publisher

verified publisherjod.li

Package maintained based on image_compare. Compare images using a variety of algorithms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

image, universal_io

More

Packages that depend on image_compare_2