idata_pda 0.0.4 copy "idata_pda: ^0.0.4" to clipboard
idata_pda: ^0.0.4 copied to clipboard

pda with idata

3
likes
135/ 160
pub points
55%
popularity

We analyzed this package 2 days ago, and awarded it 135 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

9 out of 21 API elements (42.9 %) have documentation comments.

Some symbols that are missing documentation: idata_pda, idata_pda.IdataPda, idata_pda.IdataPda.IdataPda, idata_pda.IdataPda.enableAddKeyValue, pda_scan_mixin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:idata_pda/idata_pda.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:idata_pda/idata_pda.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:idata_pda/idata_pda.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:idata_pda/idata_pda.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: The import of 'package:flutter/material.dart' is unnecessary because all of the used elements are also provided by the import of 'package:flutter/services.dart'.

lib/pda_utils.dart:3:8

  ╷
3 │ import 'package:flutter/material.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/pda_utils.dart

lib/pda_scan_mixin.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

3
likes
135
pub points
55%
popularity

Publisher

unverified uploader

pda with idata

Homepage

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

flutter

More

Packages that depend on idata_pda