icons_launcher 2.1.7 copy "icons_launcher: ^2.1.7" to clipboard
icons_launcher: ^2.1.7 copied to clipboard

A command-line tool that simplifies the task of updating your Flutter app's launcher icon.

578
likes
140/ 140
pub points
97%
popularity

We analyzed this package 15 hours ago, and awarded it 140 pub points (of a possible 140):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/mrrhak/icons_launcher/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

128 out of 134 API elements (95.5 %) have documentation comments.

Some symbols that are missing documentation: cli_logger, constants, icon, icons_launcher_cli, template.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:icons_launcher/cli_commands.dart that imports:
  • package:icons_launcher/utils/utils.dart that imports:
  • package:universal_io/io.dart that imports:
  • package:universal_io/src/_exports_in_browser.dart that imports:
  • package:universal_io/src/internet_address.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.2 2.5.0 2.5.0
image ^4.1.3 4.2.0 4.2.0
path >=1.8.2 <2.0.0 1.9.0 1.9.0
universal_io ^2.2.2 2.2.2 2.2.2
yaml ^3.1.2 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
archive - 3.6.0 3.6.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
meta - 1.15.0 1.15.0
petitparser - 6.0.2 6.0.2
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
xml - 6.5.0 6.5.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

578
likes
140
pub points
97%
popularity
screenshot

Publisher

verified publishermrrhak.com

A command-line tool that simplifies the task of updating your Flutter app's launcher icon.

Homepage
Repository (GitHub)
View/report issues
Contributing

Topics

#icons #app-icon #icon-launcher

Documentation

API reference

Funding

Consider supporting this project:

ko-fi.com

License

MIT (LICENSE)

Dependencies

args, image, path, universal_io, yaml

More

Packages that depend on icons_launcher