iconfont_dart 0.3.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 87

iconfont_dart #

导入 iconfont,只需要编译一次,就可以帮你快速生成 icon。

To import iconcont, you only need to compile it once to help you generate icons quickly.

目录 #

预览 #

使用 #

main() {
  IconfontDart(
    '../lib/assets/fonts/demo_index.html',
    './a.dart'
  );
}

注意:通过 dart xxx.dart 执行生成 dart 文件

参数说明 #

参数说明
diriconfont 中 demo_index.html 目录
buildDir生成 dart 文件路径
className生成的类名

相关插件 #

插件说明
html解析 html

维护者 #

@meetqy.

欢迎 PR #

非常欢迎你的加入! 提一个 Issue 或者提交一个 Pull Request.

使用许可 #

MIT © MEETQY

0.3.3 #

  • 更新文档

0.3.2 #

  • 更新文档

0.3.1 #

  • 更新预览图

0.3.0 #

  • 修改生成的文件,和flutter自带的Icons调用方式一致
  • 删除IconfontDart多余的参数,整理注释

0.2.1 #

  • 增加可以自定义默认字体大小

0.2.0 #

0.1.5 #

  • 修改名字

0.1.4 #

  • 修改size属性为double

0.1.3 #

  • 修改包名

0.1.2 #

  • Color方法增加可选参数

0.1.1 #

  • classname增加驼峰配置

0.1.0 #

  • 发布0.1.0版本

0.0.4 #

  • 优化生成dart文件格式
  • 增加readme.md

0.0.3 #

  • 修改描述

0.0.2 #

  • 修改iconfont_dart调用方式
  • 增加对iconfont_dart库的描述

0.0.1 #

  • demo版本

example/main.dart

import 'package:iconfont_dart/iconfont_dart.dart';

main() {
  IconfontDart(
    '../lib/assets/fonts/demo_index.html', 
    './a.dart'
  );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  iconfont_dart: ^0.3.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:iconfont_dart/iconfont_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.2

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
html ^0.14.0+2 0.14.0+3
Transitive dependencies
charcode 1.1.2
collection 1.14.11 1.14.12
csslib 0.16.1
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.5.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test