icon_font_generator 4.0.0 copy "icon_font_generator: ^4.0.0" to clipboard
icon_font_generator: ^4.0.0 copied to clipboard

Converts SVG icons to OTF font and generates Flutter-compatible class. Provides an API and a CLI tool.

108
likes
140/ 160
pub points
87%
popularity

We analyzed this package 39 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

33 out of 113 API elements (29.2 %) have documentation comments.

Some symbols that are missing documentation: icon_font_generator, icon_font_generator.ChecksumException, icon_font_generator.ChecksumException.ChecksumException, icon_font_generator.ChecksumException.entityName, icon_font_generator.ChecksumException.ChecksumException.font.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:icon_font_generator/icon_font_generator.dart that imports:
  • package:icon_font_generator/src/utils.dart that imports:
  • package:icon_font_generator/src/utils/flutter_class_gen.dart that imports:
  • package:icon_font_generator/src/otf/defaults.dart that imports:
  • package:icon_font_generator/src/utils/otf.dart that imports:
  • package:icon_font_generator/src/otf/table/head.dart that imports:
  • package:icon_font_generator/src/otf/table/all.dart that imports:
  • package:icon_font_generator/src/otf/table/post.dart that imports:
  • package:icon_font_generator/src/otf/debugger.dart that imports:
  • package:icon_font_generator/src/utils/logger.dart that imports:
  • package:logger/logger.dart that imports:
  • package:logger/src/outputs/file_output_stub.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'whereNotNull' is deprecated and shouldn't be used. Use .nonNulls instead.

lib/src/cli/arguments.dart:225:64

    ╷
225 │       iconFontGeneratoryamlmap.entries.map(_mapConfigKeyEntry).whereNotNull();
    │                                                                ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/cli/arguments.dart

INFO: The part-of directive uses a library name.

lib/src/otf/cff/charset.dart:1:1

  ╷
1 │ part of icon_font_generator.otf.cff;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/otf/cff/charset.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.0 2.5.0 2.5.0
collection ^1.17.0 1.19.0 1.19.0
dart_style ^2.3.0 2.3.6 2.3.6
logger ^1.3.0 1.4.0 2.3.0
meta ^1.8.0 1.15.0 1.15.0
path ^1.8.2 1.9.0 1.9.0
path_parsing ^1.0.1 1.0.1 1.0.1
recase ^4.1.0 4.1.0 4.1.0
vector_math ^2.1.4 2.1.4 2.1.4
xml ^6.2.2 6.5.0 6.5.0
yaml ^3.1.1 3.1.2 3.1.2
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 68.0.0 72.0.0
_macros - 0.1.0 0.1.0
analyzer - 6.5.0 6.7.0
async - 2.11.0 2.11.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
macros - 0.1.0-main.0 0.1.2-main.4
package_config - 2.1.0 2.1.0
petitparser - 6.0.2 6.0.2
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.3.0` on logger does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions logger to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

108
likes
140
pub points
87%
popularity

Publisher

verified publisherserge.software

Converts SVG icons to OTF font and generates Flutter-compatible class. Provides an API and a CLI tool.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

args, collection, dart_style, logger, meta, path, path_parsing, recase, vector_math, xml, yaml

More

Packages that depend on icon_font_generator