huskyclient 0.0.7
huskyclient: ^0.0.7 copied to clipboard

dart husky client library for ebox. currently only dart native is supported. but vpn version is under workiing.

1
likes
60/ 130
pub points
0%
popularity

We analyzed this package on Sep 16, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/huskyclient_example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 348 out of 3147 API elements (11.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:huskyclient/huskyclient.dart that imports:
  • package:huskyclient/src/huskyclient_base.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/proto/dart/box/account.pb.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/proto/dart/box/api.pb.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
fixnum^0.10.110.10.111.0.0
meta^1.2.41.7.01.7.0
protobuf^1.1.01.1.42.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.10.11` on fixnum does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions fixnum to update the constraint.

The constraint `^1.1.0` on protobuf does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions protobuf to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.10.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.20.0, Dart 2.14.0.

1
likes
60
pub points
0%
popularity

Publisher

etsus.net

dart husky client library for ebox. currently only dart native is supported. but vpn version is under workiing.

Homepage

Documentation

API reference

License

MIT (LICENSE)

Dependencies

fixnum, meta, protobuf

More

Packages that depend on huskyclient