html_unescape 1.0.0

  • Example
  • Installing
  • Versions
  • 46

html_unescape #

Build Status

A Dart library for unescaping HTML-encoded strings.


  • Named Character References ( )
    • 2099 of them
  • Decimal Character References (á)
  • Hexadecimal Character References (ã)

The idea is that while you seldom need encoding to such a level (most of the time, all you need to escape is <, >, /, & and "), you do want to make sure that you cover the whole spectrum when decoding from HTML-escaped strings.

Inspired by Java's unbescape library.

Usage #

A simple usage example:

import 'package:html_unescape/html_unescape.dart';

main() {
  var unescape = new HtmlUnescape();
  var text = unescape.convert("&lt;strong&#62;This &quot;escaped&quot; string");

You can also use the converter to transform a stream. For example, the code below will transform a POSIX stdin into an HTML-unencoded stdout.

await stdin
    .transform(new Utf8Decoder())
    .transform(new HtmlUnescape())
    .transform(new Utf8Encoder())

Full versus small #

If you're sure you will only encounter the most common escaped characters, you can import 'package:html_unescape/html_unescape_basic.dart' instead of the full version. This will decrease code size and increase performance. The only difference is in the size of the Named Character Reference dictionary. The full set includes the likes of &DownLeftRightVector; or &UpArrowBar; while the small set only includes the first 255 charcodes.

Issues #

Please use GitHub tracker. Don't hesitate to create pull requests, too.

Changelog #

1.0.0 #

  • Bump to 1.0. The package has baked for 2 years now.

0.1.5 #

  • Remove deprecated dependency on ChunkedConverter (author: @andresaraujo)
  • Loosen dev dependency on path

older #

(No records. Please see commit history.)


// Copyright (c) 2018, Filip Hracek. All rights reserved. Use of this source
// code is governed by a BSD-style license that can be found in the LICENSE
// file.

import 'package:html_unescape/html_unescape.dart';

void main() {
  var unescape = new HtmlUnescape();
  print(unescape.convert("&lt;strong&#62;This &quot;escaped&quot; string "
      "will be printed normally.</strong>"));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  html_unescape: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:html_unescape/html_unescape.dart';
Version Uploaded Documentation Archive
1.0.1+2 Jul 26, 2018 Go to the documentation of html_unescape 1.0.1+2 Download html_unescape 1.0.1+2 archive
1.0.1+1 Jul 23, 2018 Go to the documentation of html_unescape 1.0.1+1 Download html_unescape 1.0.1+1 archive
1.0.1 Jul 23, 2018 Go to the documentation of html_unescape 1.0.1 Download html_unescape 1.0.1 archive
1.0.0 May 18, 2018 Go to the documentation of html_unescape 1.0.0 Download html_unescape 1.0.0 archive
0.1.5 May 30, 2017 Go to the documentation of html_unescape 0.1.5 Download html_unescape 0.1.5 archive
0.1.4 May 25, 2016 Go to the documentation of html_unescape 0.1.4 Download html_unescape 0.1.4 archive
0.1.3 May 25, 2016 Go to the documentation of html_unescape 0.1.3 Download html_unescape 0.1.3 archive
0.1.2 May 25, 2016 Go to the documentation of html_unescape 0.1.2 Download html_unescape 0.1.2 archive
0.1.1 May 25, 2016 Go to the documentation of html_unescape 0.1.1 Download html_unescape 0.1.1 archive
0.1.0 May 25, 2016 Go to the documentation of html_unescape 0.1.0 Download html_unescape 0.1.0 archive

All 11 versions...

Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0