html5 0.1.8

  • Readme
  • Changelog
  • Installing
  • 0

HTML library for Dart / DDC (polymerize) #

This library is an HTML library generated by html_wrapper_generator starting from webidl files (stolen from the firefox project and then adapted).

It leverages the @JS interop Dart layer and aims to completely replace the (at the moment) out dated dart:html library.

As a separate package from the SDK this library has the main advantage to be updated more frequently.

Notably this library adds support to latest standards:

  • WebComponents v1
  • ShadowDom

Demo project #

See here for a demo project using polymerize and this library.

v0.1.8 #

  • using build sourge_gen
  • added dart2ts demo
  • upgraded shadowDOM webidl

v0.1.7 #

  • added MessageEvent and onMessage EventStreamProvider.
  • moved support for http in a different package
  • added Console
  • added support for URL, ProgressEvent, DragEvent, FileSystem

v0.1.6 #

  • added FileReader
  • added support for http (v0.12-dev)

v0.1.5 #

  • added DocumentOrShadowRoot
    • WARN : DocumentOrShadowRoot is not implemented in ShadyDOM (=> Firefox, etc.) see here
  • added some more utils, some copied from dart:html, notably:
    • key codes
    • a simplified version of EventStreamProvider
    • some event stream providers

v0.1.4 #

  • better support for HttpRequest

v0.1.3 #

  • added service workers API

v0.1.2+1 #

  • added missing KeyboardEvent (!!)

v0.1.1 #

v0.1.0 #

  • working with pub+ddc dart 1.24

v0.0.7 #

  • fixed an issue being too aggressive removing dart._extensionType marker

v0.0.6 #

  • support for latest polymerize (^0.8.1)

v0.0.5 #

  • Changed module name convention

v0.0.3 #

  • added factory
  • switched to abstract classes with implements
  • added XMLHttpRequest
  • added Promise and asFuture

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  html5: ^0.1.8

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:html5/html.dart';
import 'package:html5/html.polymerize.dart';
import 'package:html5/html5_support.dart';
import 'package:html5/html5_support.polymerize.dart';
import 'package:html5/html_addendum.dart';
import 'package:html5/html_gen.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0