howler 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 59

howler.dart

Description #

howler.dart is an audio library for the modern web. It defaults to Web Audio API and falls back to HTML5 Audio. This makes working with audio in Dart easy and reliable across all platforms.

Additional information, live demos and a user showcase are available at howlerjs.com.

Usage #

A simple usage example:

import 'package:howler/howler.dart';

main() {

    var howl = new Howl(
        src: ['audio/track.mp3','audio/track.wav'], // source in MP3 and WAV fallback
        loop: true,
        volume: 0.60 // Play with 60% of original volume.
    ) ;
    
    howl.play(); // Play sound.
    howl.fade(0.0, 0.60, 10000) ; // Make a fade, from volume 0% to 60% in 10s

}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Author #

Graciliano M. Passos: gmpassos@GitHub.

License #

MIT license.

Original project in JavaScript #

This library was originally written in JavaScript by James Simpson. It was ported to Dart 2 code by Graciliano M. Passos.

You can find the original project at GitHub(howler.js).

Project site: howlerjs.com

1.0.1 #

  • Added logo images.

1.0.0 #

example/howler_example.dart

import 'package:howler/howler.dart';

main() {
  var awesome = Awesome();
  print('awesome: ${awesome.isAwesome}');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  howler: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:howler/howler.dart';
  
Version Uploaded Documentation Archive
1.0.3 Apr 20, 2019 Go to the documentation of howler 1.0.3 Download howler 1.0.3 archive
1.0.2 Jan 6, 2019 Go to the documentation of howler 1.0.2 Download howler 1.0.2 archive
1.0.1 Jan 6, 2019 Go to the documentation of howler 1.0.1 Download howler 1.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
69
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on May 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16

Platforms

Detected platforms: web

Primary library: package:howler/howler.dart with components: html.

Health suggestions

Fix lib/src/howler_base.dart. (-31.34 points)

Analysis of lib/src/howler_base.dart reported 75 hints, including:

line 35 col 12: Don't explicitly initialize variables to null.

line 39 col 16: Don't explicitly initialize variables to null.

line 65 col 3: Prefer using /// for doc comments.

line 112 col 3: Prefer using /// for doc comments.

line 151 col 3: Prefer using /// for doc comments.

Format lib/howler.dart.

Run dartfmt to format lib/howler.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
swiss_knife ^2.0.0 2.0.0
Transitive dependencies
intl 0.15.8
path 1.6.2
Dev dependencies
test ^1.5.1