hotreloader 2.0.0

Dart native
Flutter Android iOS

Hot code reloader

6
likes
70 / 110
pub points
27 %
popularity

We analyzed this package on Sep 19, 2020, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 23 API elements (47.8 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:hotreloader/hotreloader.dart that imports:
  • package:hotreloader/src/util/vm.dart that imports:
  • package:vm_service/vm_service_io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

INFO: Prefer using /// for doc comments.

lib/hotreloader.dart:1:1

  ╷
1 │ ┌ /**
2 │ │  * Copyright 2020 by Vegard IT GmbH (https://vegardit.com) and contributors.
3 │ │  * SPDX-License-Identifier: Apache-2.0
4 │ │  *
5 │ │  * @author Sebastian Thomschke, Vegard IT GmbH
6 │ └  */
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/hotreloader.dart

INFO: Unnecessary new keyword.

lib/hotreloader.dart:25:14

   ╷
25 │ final _LOG = new logging.Logger('hotreloader');
   │              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/hotreloader.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging^0.11.3+20.11.40.11.4
path^1.6.31.7.01.7.0
stream_transform^1.0.01.2.01.2.0
vm_service^4.0.04.2.05.1.0+1
watcher^0.9.7+100.9.7+150.9.7+15
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
collection-1.14.131.14.13
meta-1.2.31.2.3
pedantic-1.9.21.9.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.0` on vm_service does not support the latest published version `5.1.0+1`

pubspec.yaml:21:15

   ╷
21 │   vm_service: ^4.0.0       # https://pub.dev/packages/vm_service
   │               ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs