horizontal_date_picker 0.0.1
horizontal_date_picker: ^0.0.1 copied to clipboard

Flutter Android iOS

A new flutter plugin project.

0
likes
70 / 110
pub points
10 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/mohammadshrahi/HorizontalDatePicker was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 25 out of 51 API elements (49.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:horizontal_date_picker/horizontal_date_picker.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unused import: 'package:horizontal_date_picker/date_helper.dart'.

lib/date_row.dart:2:8

  ╷
2 │ import 'package:horizontal_date_picker/date_helper.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/date_row.dart

INFO: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: DateRow.width, DateRow.background, DateRow.selectedMonthStyle, DateRow.selectedDayStyle, DateRow.selectedDayOfWeekStyle

lib/date_row.dart:6:7

  ╷
6 │ class DateRow extends StatelessWidget {
  │       ^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/date_row.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
intl^0.15.80.15.80.17.0
swipedetector^1.2.01.2.01.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.15.8` on intl does not support the stable version `0.16.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.