holaa 0.0.3
holaa: ^0.0.3 copied to clipboard

A Flutter package for integrating holaa.ai chatbot.

3
likes
60 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 7 out of 48 API elements (14.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:holaa/holaa.dart that imports:
  • package:holaa/Screens/ChatScreen.dart that imports:
  • package:fluttertoast/fluttertoast.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/Constant/Constant.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/Screens/ChatScreen.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
fluttertoast^3.1.33.1.38.0.6
http^0.12.0+40.12.20.13.3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
http_parser-3.1.44.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.1.3` on fluttertoast does not support the stable version `4.0.0`.

Try running dart pub upgrade --major-versions fluttertoast to update the constraint.

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

3
likes
60
pub points
0%
popularity

A Flutter package for integrating holaa.ai chatbot.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

devpranoy@gmail.com

License

MIT (LICENSE)

Dependencies

flutter, fluttertoast, http

More

Packages that depend on holaa