hive_generator 0.5.1
hive_generator: ^0.5.1 copied to clipboard

Extension for Hive. Automatically generates TypeAdapters to store any class.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add hive_generator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  hive_generator: ^0.5.1

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:hive_generator/hive_generator.dart';
81
likes
80
pub points
96%
popularity

Publisher

hivedb.dev

Extension for Hive. Automatically generates TypeAdapters to store any class.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

analyzer, build, hive, source_gen

More

Packages that depend on hive_generator