hive_generator 0.8.2
hive_generator: ^0.8.2 copied to clipboard

Dart native

Extension for Hive. Automatically generates TypeAdapters to store any class.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  hive_generator: ^0.8.2

2. Install it

You can install packages from the command line:

with pub:

$ dart pub get

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:hive_generator/hive_generator.dart';
56
likes
80
pub points
94%
popularity

Publisher

hivedb.dev

Extension for Hive. Automatically generates TypeAdapters to store any class.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Apache 2.0 (LICENSE)

Dependencies

analyzer, build, dartx, hive, source_gen

More

Packages that depend on hive_generator