history_state_notifier 0.0.6+1 copy "history_state_notifier: ^0.0.6+1" to clipboard
history_state_notifier: ^0.0.6+1 copied to clipboard

Extends state_notifier to add a history feature that allows for undo/redo operations.

16
likes
110/ 140
pub points
40%
popularity

We analyzed this package 4 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

24 out of 25 API elements (96.0 %) have documentation comments.

Some symbols that are missing documentation: history_state_notifier.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The annotation 'mustCallSuper' can only be used on fields, getters, methods, or setters.

lib/src/history_state_notifier.dart:18:4

   ╷
18 │   @mustCallSuper
   │    ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/history_state_notifier.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
meta ^1.7.0 1.14.0 1.14.0
state_notifier ^0.7.2+1 0.7.2+1 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.7.2+1` on state_notifier does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions state_notifier to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

16
likes
110
pub points
40%
popularity

Publisher

verified publishertimcreated.it

Extends state_notifier to add a history feature that allows for undo/redo operations.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta, state_notifier

More

Packages that depend on history_state_notifier