hijri_picker 0.0.35

Hijri Date Picker #

Hijri calender to pick umm alqura dates support max & min dates

Simple Usage #

 final ummAlquraCalendar picked = await showHijriDatePicker(
       context: context,
       initialDate: selectedDate,
       lastDate: new ummAlquraCalendar()
         ..hYear = 1442
         ..hMonth = 9
         ..hDay = 25,
       firstDate: new ummAlquraCalendar()
         ..hYear = 1438
         ..hMonth = 12
         ..hDay = 25,
       initialDatePickerMode: DatePickerMode.day,
     );

About #

screenshots #

by #

Ahmed Aljoaid 👨🏻‍💻

Changelog #

0.0.1 #

  • Initial version

example/README.md

Hijri Date Picker #

Hijri calender to pick umm alqura dates support max & min dates

Simple Usage #

 final ummAlquraCalendar picked = await showHijriDatePicker(
       context: context,
       initialDate: selectedDate,
       lastDate: new ummAlquraCalendar()
         ..hYear = 1442
         ..hMonth = 9
         ..hDay = 25,
       firstDate: new ummAlquraCalendar()
         ..hYear = 1438
         ..hMonth = 12
         ..hDay = 25,
       initialDatePickerMode: DatePickerMode.day,
     );

About #

screenshots #

by #

Ahmed Aljoaid 👨🏻‍💻

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  hijri_picker: ^0.0.35

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:hijri_picker/hijri_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/hijri_picker.dart.

Run flutter format to format lib/hijri_picker.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
hijri ^0.2.5 0.2.5
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_driver

Admin