hetu_script 0.4.2+1 copy "hetu_script: ^0.4.2+1" to clipboard
hetu_script: ^0.4.2+1 copied to clipboard

Hetu is a lightweight scripting language for embedding in Flutter apps.

43
likes
110/ 140
pub points
71%
popularity

We analyzed this package 6 days ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

729 out of 2975 API elements (24.5 %) have documentation comments.

Some symbols that are missing documentation: abstract_parameter, abstract_parameter.HTAbstractParameter.declType, abstract_parameter.HTAbstractParameter.initialize, abstract_parameter.HTAbstractParameter.isInitialization, abstract_parameter.HTAbstractParameter.isNamed.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

WARNING: Duplicate import.

lib/analyzer/analysis_manager.dart:3:8

  ╷
3 │ import '../ast/ast.dart';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/analyzer/analysis_manager.dart

WARNING: Duplicate export.

lib/declarations.dart:9:8

  ╷
9 │ export 'declaration/type/abstract_type_declaration.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/declarations.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
characters ^1.2.0 1.3.0 1.3.0
fast_noise ^1.0.1 1.0.1 2.0.0
intl ^0.17.0 0.17.0 0.19.0
meta ^1.7.0 1.14.0 1.14.0
path ^1.8.0 1.9.0 1.9.0
pub_semver ^2.1.0 2.1.4 2.1.4
quiver ^3.0.1 3.2.1 3.2.1
recase ^4.0.0 4.1.0 4.1.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fixnum - 1.1.0 1.1.0
matcher - 0.12.16+1 0.12.16+1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.1 0.7.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on fast_noise does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions fast_noise to update the constraint.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

43
likes
110
pub points
71%
popularity

Publisher

verified publisherhetu.dev

Hetu is a lightweight scripting language for embedding in Flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

characters, fast_noise, intl, meta, path, pub_semver, quiver, recase

More

Packages that depend on hetu_script