helper 0.0.14
helper: ^0.0.14 copied to clipboard

Flutter Android iOS web

Common helper that every project needs. CurrencyHelper, DateTimeHelper, FileHelper, DialogHelper

0
likes
70 / 110
pub points
55 %
popularity

We analyzed this package on Jan 26, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 52 API elements (5.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/currency_helper.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/file_helper.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cached_network_image^1.1.01.1.32.5.0
intl^0.15.80.15.80.16.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
charcode-1.1.31.2.0-nullsafety.3
clock-1.0.11.1.0-nullsafety.3
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
convert-2.1.12.1.1
crypto-2.1.52.1.5
ffi-0.1.30.1.3
file-5.2.15.2.1
flutter_cache_manager-1.4.22.1.1
http-0.12.20.12.2
http_parser-3.1.43.1.4
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
path-1.7.01.8.0-nullsafety.3
path_provider-1.6.271.6.27
path_provider_linux-0.0.1+20.0.1+2
path_provider_macos-0.0.4+80.0.4+8
path_provider_platform_interface-1.0.41.0.4
path_provider_windows-0.0.4+30.0.4+3
pedantic-1.9.21.9.2
platform-2.2.12.2.1
plugin_platform_interface-1.0.31.0.3
process-3.0.133.0.13
rxdart-0.24.10.25.0
source_span-1.7.01.8.0-nullsafety.4
sqflite-1.3.2+21.3.2+2
sqflite_common-1.0.3+11.0.3+1
string_scanner-1.0.51.1.0-nullsafety.3
synchronized-2.2.0+22.2.0+2
term_glyph-1.1.01.2.0-nullsafety.3
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
uuid-2.2.22.2.2
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5
win32-1.7.41.7.4
xdg_directories-0.1.20.1.2

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.0` on cached_network_image does not support the latest published version `2.5.0`

pubspec.yaml:14:25

   ╷
14 │   cached_network_image: ^1.1.0
   │                         ^^^^^^
   ╵
The constraint `^0.15.8` on intl does not support the latest published version `0.16.1`

pubspec.yaml:13:9

   ╷
13 │   intl: ^0.15.8
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
70
pub points
55%
popularity

Common helper that every project needs. CurrencyHelper, DateTimeHelper, FileHelper, DialogHelper

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jhanihashemi@gmail.com

License

BSD (LICENSE)

Dependencies

cached_network_image, flutter, intl

More

Packages that depend on helper