hash_compare 0.1.0+4
hash_compare: ^0.1.0+4 copied to clipboard

Hash and compare function generator

0
likes
75/ 130
pub points
0%
popularity

We analyzed this package on Nov 26, 2021, and awarded it 75 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 18 API elements (61.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.40.39.172.7.0
build^1.2.21.6.22.1.1
build_config^0.4.1+10.4.71.0.0
source_gen^0.9.4+70.9.10+21.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.030.0.0
args-1.6.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.3.04.3.0
logging-1.0.21.0.2
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
pubspec_parse-0.1.81.1.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.39.4` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.2.2` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.14.4.