hard_analyser 1.8.0 copy "hard_analyser: ^1.8.0" to clipboard
hard_analyser: ^1.8.0 copied to clipboard

A heavily opinionated analysis_options for Dart & Flutter projects

Hard Analyser #

pub package

A heavily opinionated analysis_options for Dart & Flutter projects. Sometimes being flutter_lints isn't enough.

Usage #

Add this package to your dev_dependencies in your pubspec.yaml:

dev_dependencies:
  hard_analyser: ^1.8.0

and the following to your analysis_options.yaml (create one in the root of your project if you don't have it yet):

  include: package:hard_analyser/analysis_options.yaml
3
likes
160
pub points
6%
popularity

Publisher

verified publisherluisgustavo.dev.br

A heavily opinionated analysis_options for Dart & Flutter projects

Repository (GitHub)
View/report issues

Topics

#lints #analyzer #analysis

Documentation

API reference

License

MIT (license)

More

Packages that depend on hard_analyser