gtk 0.9.8+1
gtk: ^0.9.8+1 copied to clipboard

Implements GTK Widgets, themes and titlebar buttons in Flutter. Based on the GNOME HIG

22
likes
120/ 130
pub points
67%
popularity

We analyzed this package on Oct 18, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 64 out of 176 API elements (36.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:gtk/gtk.dart that imports:
  • package:gtk/src/widgets/widgets.dart that imports:
  • package:gtk/src/widgets/gtk_view_switcher_tab.dart that imports:
  • package:gtk/src/utils/utils.dart that imports:
  • package:gtk/src/utils/gtk_colors.dart that imports:
  • package:xdg_directories/xdg_directories.dart that imports:
  • package:process/process.dart that imports:
  • package:process/src/interface/process_wrapper.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dbus>=0.6.3 <1.0.00.6.30.6.3
flutterflutter0.0.00.0.0
from_css_color>=2.0.0 <3.0.02.0.02.0.0
gsettings>=0.2.0 <1.0.00.2.00.2.0
popover>=0.2.6+2 <1.0.00.2.6+30.2.6+3
xdg_directories>=0.2.0 <1.0.00.2.00.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
platform-3.0.23.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

22
likes
120
pub points
67%
popularity

Publisher

prateeksu.blogspot.com

Implements GTK Widgets, themes and titlebar buttons in Flutter. Based on the GNOME HIG

Repository (GitHub)
View/report issues

Documentation

API reference

License

LGPL-3.0 (LICENSE)

Dependencies

dbus, flutter, from_css_color, gsettings, popover, xdg_directories

More

Packages that depend on gtk