grinder 0.8.6
grinder: ^0.8.6 copied to clipboard

Dart native

Grinder is a task runner for Dart, helping to define and automate common project workflows.

37
likes
85 / 110
pub points
85 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 133 out of 210 API elements (63.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:grinder/grinder.dart that imports:
  • package:grinder/src/grinder.dart that imports:
  • package:grinder/src/singleton.dart that imports:
  • package:grinder/src/utils.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cli_util>=0.1.2 <3.0.00.2.00.3.0
glob^1.0.01.2.02.0.0
meta^1.1.71.2.41.3.0
path^1.0.01.7.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
file-5.2.16.1.0
intl-0.16.10.17.0
js-0.6.20.6.3
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on glob does not support the stable version `2.0.0`, that was published 24 days ago.

When glob is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions glob to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.