grind_publish 1.0.0
grind_publish: ^1.0.0

Dart native

A library to automatically publish a package when its version increases.

1
likes
100 / 110
pub points
2 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 12 API elements (33.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:grind_publish/grind_publish.dart that imports:
  • package:grinder/grinder.dart that imports:
  • package:grinder/src/grinder.dart that imports:
  • package:grinder/src/singleton.dart that imports:
  • package:grinder/src/utils.dart that imports:
  • dart:mirrors
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
grinder^0.8.30.8.60.8.6
http^0.12.00.12.20.12.2
meta^1.1.01.2.41.2.4
path^1.6.01.7.01.7.0
pub_client^3.0.33.0.33.0.3
yaml^2.1.02.2.12.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
cli_util-0.2.00.2.0
collection-1.14.131.14.13
file-5.2.15.2.1
glob-1.2.01.2.0
http_parser-3.1.43.1.4
intl-0.16.10.16.1
js-0.6.20.6.2
json_annotation-2.4.03.1.1
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
100
pub points
2%
popularity

A library to automatically publish a package when its version increases.

Repository (GitLab)
View/report issues

Documentation

API reference

Uploader

matenyo@gmail.com

License

MIT (LICENSE)

Dependencies

grinder, http, meta, path, pub_client, yaml

More

Packages that depend on grind_publish