graphql_query_compress 0.0.1+1 copy "graphql_query_compress: ^0.0.1+1" to clipboard
graphql_query_compress: ^0.0.1+1 copied to clipboard

A package that eliminates unnecessary characters from a GraphQL query, saving several bytes on requests.

7
likes
150/ 160
pub points
60%
popularity

We analyzed this package 23 hours ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 8 API elements (75.0 %) have documentation comments.

Some symbols that are missing documentation: graphql_query_compress.GraphqlQueryCompressor.instance, graphql_query_compress.RequestSerializerWithCompressor.serializer.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
gql_exec ^0.4.3 0.4.3 1.0.0+1
gql_link ^0.5.1 0.5.1 1.0.0+1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
gql - 0.14.0 1.0.0+1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.3` on gql_exec does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql_exec to update the constraint.

The constraint `^0.5.1` on gql_link does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql_link to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

7
likes
150
pub points
60%
popularity

Publisher

unverified uploader

A package that eliminates unnecessary characters from a GraphQL query, saving several bytes on requests.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

gql_exec, gql_link

More

Packages that depend on graphql_query_compress