graphql_parser 1.1.4
graphql_parser: ^1.1.4 copied to clipboard

Parses GraphQL queries and schemas. Also includes classes for the GraphQL AST.

0
likes
90 / 110
pub points
74 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 279 API elements (1.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 127 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/language/ast/field.dart:19:7

   ╷
19 │       return fieldName.span.expand(selectionSet.span);
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/language/ast/field.dart

INFO: DO use curly braces for all flow control structures.

lib/src/language/ast/field.dart:21:7

   ╷
21 │ ┌       return directives.fold<FileSpan>(
22 │ └           fieldName.span, (out, d) => out.expand(d.span));
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/language/ast/field.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
charcode^1.0.01.2.01.2.0
source_span^1.0.01.8.11.8.1
string_scanner^1.0.01.1.01.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
path-1.8.01.8.0
term_glyph-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
90
pub points
74%
popularity

Parses GraphQL queries and schemas. Also includes classes for the GraphQL AST.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

charcode, source_span, string_scanner

More

Packages that depend on graphql_parser