gql_dedupe_link 2.0.3+1 copy "gql_dedupe_link: ^2.0.3+1" to clipboard
gql_dedupe_link: ^2.0.3+1 copied to clipboard

GQL Link to deduplicate identical in-flight execution requests

2
likes
130/ 140
pub points
84%
popularity

We analyzed this package 22 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

7 out of 7 API elements (100.0 %) have documentation comments.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
async ^2.5.0 2.11.0 2.11.0
gql_exec ^0.4.3 0.4.3 1.0.0+1
gql_link ^0.5.0+1 0.5.1 1.0.0+1
meta ^1.3.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
gql - 0.14.0 1.0.0+1
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
term_glyph - 1.2.1 1.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.3` on gql_exec does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql_exec to update the constraint.

The constraint `^0.5.0+1` on gql_link does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions gql_link to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

2
likes
130
pub points
84%
popularity

Publisher

verified publishergql-dart.dev

GQL Link to deduplicate identical in-flight execution requests

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async, gql_exec, gql_link, meta

More

Packages that depend on gql_dedupe_link