gps 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

gps #

Getting location data by gps, Support android and iOS.

0.1.1 GitHub

Install #

dependencies:
  gps: ^0.1.1 # (latest version)

Usage #

import 'package:gps/gps.dart';

void main() async{
  var latlng = await Gps.currentGps();
  print(latlng.lat);
  print(latlng.lng);
}

Get GPS information only once.

LICENSE #

MIT

0.1.0 #

First commit

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:gps/gps.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  GpsLatlng latlng;

  @override
  void initState() {
    super.initState();
    initGps();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('gps is :$latlng'),
        ),
      ),
    );
  }

  void initGps() async {
    var gps = await Gps.currentGps();
    this.latlng = gps;
    setState(() {});
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  gps: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:gps/gps.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
72
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
93
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:gps/gps.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:gps/gps.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:gps/gps.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:gps/gps.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [gps] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

10 out of 10 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

Package is getting outdated. (-7.40 points)

The package was last published 56 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test