googlecloudspeech 0.1.3 icon indicating copy to clipboard operation
googlecloudspeech: ^0.1.3 copied to clipboard

PlatformAndroid

Flutter plugin for google speech api

2
likes
90/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 13 API elements (30.8 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android

These platforms are not supported:

Package does not support platform `iOS`.

Because:

  • package:googlecloudspeech/googlecloudspeech.dart that declares support for platforms: Android.
Package does not support platform `Windows`.

Because:

  • package:googlecloudspeech/googlecloudspeech.dart that declares support for platforms: Android.
Package does not support platform `Linux`.

Because:

  • package:googlecloudspeech/googlecloudspeech.dart that declares support for platforms: Android.
Package does not support platform `macOS`.

Because:

  • package:googlecloudspeech/googlecloudspeech.dart that declares support for platforms: Android.
Package does not support platform `Web`.

Because:

  • package:googlecloudspeech/googlecloudspeech.dart that declares support for platforms: Android.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: The variable name 'v1_list' isn't a lowerCamelCase identifier.

lib/googlecloudspeech.dart:11:39

   ╷
11 │   static Future<Map<String, dynamic>> v1_list(Map<String, String> config, String api_key) async {
   │                                       ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/googlecloudspeech.dart

INFO: The variable name 'api_key' isn't a lowerCamelCase identifier.

lib/googlecloudspeech.dart:11:82

   ╷
11 │   static Future<Map<String, dynamic>> v1_list(Map<String, String> config, String api_key) async {
   │                                                                                  ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/googlecloudspeech.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.10.12.20.13.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
charcode-1.3.11.3.1
collection-1.17.01.17.1
http_parser-3.1.44.0.2
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
meta-1.8.01.9.0
path-1.8.31.8.3
pedantic-1.11.11.11.1
sky_engine-0.0.990.0.99
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

2
likes
90
pub points
0%
popularity

Publisher

verified publisher iconakashrajkn.wtf

Flutter plugin for google speech api

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http

More

Packages that depend on googlecloudspeech