google_sign_in_all 0.0.3
google_sign_in_all: ^0.0.3 copied to clipboard

Flutter Google Sign In wrapper on `googleapis_auth` (Web) and `google_sign_in` (Android/iOS)

2
likes
100 / 130
pub points
66 %
popularity

We analyzed this package on Jun 18, 2021, and awarded it 100 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 17 API elements (23.5 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform Windows

Because:

  • package:google_sign_in_all/google_sign_in_all.dart that imports:
  • package:google_sign_in_all/src/mobile.dart that imports:
  • package:google_sign_in/google_sign_in.dart that declares support for platforms: Android, iOS, Web
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
google_sign_in^4.0.74.5.95.0.4
googleapis_auth^0.2.100.2.12+11.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
crypto-3.0.13.0.1
flutter_web_plugins-0.0.00.0.0
google_sign_in_platform_interface-1.1.22.0.1
google_sign_in_web-0.9.20.10.0
http-0.12.20.13.3
http_parser-3.1.44.0.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.4.0
path-1.8.01.8.0
pedantic-1.11.11.11.1
quiver-2.1.53.0.1
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^4.0.7` on google_sign_in does not support the stable version `5.0.0`.

Try running dart pub upgrade --major-versions google_sign_in to update the constraint.

The constraint `^0.2.10` on googleapis_auth does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions googleapis_auth to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.18.2, Flutter 2.2.2, Dart 2.13.3.

2
likes
100
pub points
66%
popularity

Publisher

Unknown

Flutter Google Sign In wrapper on `googleapis_auth` (Web) and `google_sign_in` (Android/iOS)

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, google_sign_in, googleapis_auth

More

Packages that depend on google_sign_in_all